SupportBee Now Supports Internet Explorer 9+

We have some good news to share with you. As many of you might have noticed, SupportBee, our Help Desk Software didn’t work on Microsoft’s Internet Explorer browser. It must have disappointed you if you were an IE user. We worked pretty hard to change this and finally we made it work! SupportBee now works flawlessly with Internet Explorer version 9+.

Now, if you have been using older versions of Internet Explorer, you really need to update. The latest version brings many features and functionalities. It’s also highly recommended by Microsoft to update your browser for security and stability reasons. So, if you’re using Internet Explorer as your primary or secondary browser, update it right away. Then you can enjoy all the cool functionality and features of SupportBee using Internet Explorer 9.

To update your Internet Explorer to 9, please visit the upgrade link. Download the updater and run it. It will then download and install the latest version of Internet Explorer on your computer. (You will need to restart your computer for the changes to take effect, though).

Hana Mohan

Hana Mohan